import Foundation
let pattern = #"\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
52,52d
65.00f
123,50
1,234,567,89
1,234,567.89
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)