re = /\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b/m
str = '52,52d
65.00f
123,50
1,234,567,89
1,234,567.89'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result