using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b";
string substitution = @".";
string input = @"52,52d
65.00f
123,50
1,234,567,89
1,234,567.89";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}