package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b`)
var str = `52,52d
65.00f
123,50
1,234,567,89
1,234,567.89`
var substitution = "."
fmt.Println(re.ReplaceAllString(str, substitution))
}