import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+(?:\\,\\d+)*(?:\\.\\d+)?[fd]?\\b";
final String string = "52,52d\n"
+ "65.00f\n"
+ "123,50\n"
+ "1,234,567,89\n"
+ "1,234,567.89";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}