import re
regex = re.compile(r"\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b", flags=re.MULTILINE)
test_str = ("52,52d\n"
"65.00f\n"
"123,50\n"
"1,234,567,89\n"
"1,234,567.89")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)