// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b").unwrap();
let string = "52,52d
65.00f
123,50
1,234,567,89
1,234,567.89";
let substitution = ".";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}