const regex = /\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+(?:\\,\\d+)*(?:\\.\\d+)?[fd]?\\b', 'gm')
const str = `52,52d
65.00f
123,50
1,234,567,89
1,234,567.89`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);