# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(price=)\([^()]*?value=([\d.]+)\)/\1\2/gm;t' <<< "product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity"