# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(price=)\([^()]*?value=([\d.]+)\)"
test_str = ("product,price=(decimals=4, value=7.505),quantity\n"
"product,(subporduct,(price=(decimals=4, value=7.05)),quantity\n"
"product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.