import Foundation
let pattern = #"(price=)\([^()]*?value=([\d.]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)