import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(price=)\\([^()]*?value=([\\d.]+)\\)";
final String string = "product,price=(decimals=4, value=7.505),quantity\n"
+ "product,(subporduct,(price=(decimals=4, value=7.05)),quantity\n"
+ "product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}