using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(price=)\([^()]*?value=([\d.]+)\)";
string substitution = @"\1\2";
string input = @"product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}