re = /(price=)\([^()]*?value=([\d.]+)\)/m
str = 'product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result