use strict;
my $str = 'product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity';
my $regex = qr/(price=)\([^()]*?value=([\d.]+)\)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";