$re = '/(price=)\([^()]*?value=([\d.]+)\)/m';
$str = 'product,price=(decimals=4, value=7.505),quantity
product,(subporduct,(price=(decimals=4, value=7.05)),quantity
product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;