#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(price=)\([^()]*?value=([\d.]+)\)"
Local $sString = "product,price=(decimals=4, value=7.505),quantity" & @CRLF & _
"product,(subporduct,(price=(decimals=4, value=7.05)),quantity" & @CRLF & _
"product,(subporduct,item=2, price=(decimals=4, value=7.05)),quantity"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)