import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(?<CONYY>\\w{3,}\\d{2})(\\/resources)*(\\/?|(\\/)*|(?<FILE>\\/index\\.html))$";
final String string = "/yvr18/resources/index.html\n"
+ "/yvr18/resources/\n"
+ "/hkg18/index.html\n"
+ "/hkg18/";
final String subst = "/resources/$<CONYY>/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}