use strict;
my $str = '/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/';
my $regex = qr/^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$/mp;
my $subst = '/resources/$<CONYY>/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";