const regex = /^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(?<CONYY>\\w{3,}\\d{2})(\\\/resources)*(\\\/?|(\\\/)*|(?<FILE>\\\/index\\.html))$', 'gm')
const str = `/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/`;
const subst = `/resources/$<CONYY>/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);