re = /^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$/m
str = '/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/'
subst = '/resources/$<CONYY>/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result