import Foundation
let pattern = #"^\/(?<CONYY>\w{3,}\d{2})(\/resources)*(\/?|(\/)*|(?<FILE>\/index\.html))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/yvr18/resources/index.html
/yvr18/resources/
/hkg18/index.html
/hkg18/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/resources/$<CONYY>/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)