#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^"\S]+\/\/.+$"
Local $sString = "{" & @CRLF & _
" // regex is cool" & @CRLF & _
" "property": "http://regeixisfun.com", // regex is still cool" & @CRLF & _
"// http://regexisfun.com" & @CRLF & _
" "property2": "One//regex//is//fun"" & @CRLF & _
"// regex is very "cool"" & @CRLF & _
" "property3": "regex"," & @CRLF & _
" //// regex is really "cool"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")