import re
regex = re.compile(r"[^\"\S]+\/\/.+$", flags=re.MULTILINE)
test_str = ("{\n"
" // regex is cool\n"
" \"property\": \"http://regeixisfun.com\", // regex is still cool\n"
"// http://regexisfun.com\n"
" \"property2\": \"One//regex//is//fun\"\n"
"// regex is very \"cool\"\n"
" \"property3\": \"regex\",\n"
" //// regex is really \"cool\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")