use strict;
my $str = '{
// regex is cool
"property": "http://regeixisfun.com", // regex is still cool
// http://regexisfun.com
"property2": "One//regex//is//fun"
// regex is very "cool"
"property3": "regex",
//// regex is really "cool"
}';
my $regex = qr/[^"\S]+\/\/.+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}