import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\"\\S]+\\/\\/.+$";
final String string = "{\n"
+ " // regex is cool\n"
+ " \"property\": \"http://regeixisfun.com\", // regex is still cool\n"
+ "// http://regexisfun.com\n"
+ " \"property2\": \"One//regex//is//fun\"\n"
+ "// regex is very \"cool\"\n"
+ " \"property3\": \"regex\",\n"
+ " //// regex is really \"cool\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}