package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^"\S]+\/\/.+$`)
var str = `{
// regex is cool
"property": "http://regeixisfun.com", // regex is still cool
// http://regexisfun.com
"property2": "One//regex//is//fun"
// regex is very "cool"
"property3": "regex",
//// regex is really "cool"
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}