const regex = /[^"\S]+\/\/.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^"\\S]+\\\/\\\/.+$', 'gm')
const str = `{
// regex is cool
"property": "http://regeixisfun.com", // regex is still cool
// http://regexisfun.com
"property2": "One//regex//is//fun"
// regex is very "cool"
"property3": "regex",
//// regex is really "cool"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}