using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""\S]+\/\/.+$";
string input = @"{
// regex is cool
""property"": ""http://regeixisfun.com"", // regex is still cool
// http://regexisfun.com
""property2"": ""One//regex//is//fun""
// regex is very ""cool""
""property3"": ""regex"",
//// regex is really ""cool""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}