// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[^"\S]+\/\/.+$"#).unwrap();
let string = "{
// regex is cool
\"property\": \"http://regeixisfun.com\", // regex is still cool
// http://regexisfun.com
\"property2\": \"One//regex//is//fun\"
// regex is very \"cool\"
\"property3\": \"regex\",
//// regex is really \"cool\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}