# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ ([a-z]\)) /\n$1/gm;t' <<< "a) ciao bau miao b) viva gianni c) ciro dorme"