use strict;
my $str = 'a) ciao bau miao b) viva gianni c) ciro dorme';
my $regex = qr/ ([a-z]\)) /mp;
my $subst = '\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";