re = / ([a-z]\)) /m
str = 'a) ciao bau miao b) viva gianni c) ciro dorme'
subst = '\\n$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result