const regex = / ([a-z]\)) /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' ([a-z]\\)) ', 'gm')
const str = `a) ciao bau miao b) viva gianni c) ciro dorme`;
const subst = `\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);