import Foundation
let pattern = #" ([a-z]\)) "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a) ciao bau miao b) viva gianni c) ciro dorme"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)