package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) ([a-z]\)) `)
var str = `a) ciao bau miao b) viva gianni c) ciro dorme`
var substitution = "\n$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}