// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) ([a-z]\)) ").unwrap();
let string = "a) ciao bau miao b) viva gianni c) ciro dorme";
let substitution = "\\n$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}