#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "&#\w+;(*SKIP)(*F)|;"
Local $sString = "ć;" & @CRLF & _
"Johć; Smith <js@comms.com>;" & @CRLF & _
";boomʿ;woopwoop;" & @CRLF & _
";"
Local $sSubst = "<NEW>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)