const regex = /&#\w+;(*SKIP)(*F)|;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&#\\w+;(*SKIP)(*F)|;', 'g')
const str = `ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;`;
const subst = `<NEW>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);