// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"&#\w+;(*SKIP)(*F)|;").unwrap();
let string = "ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;";
let substitution = "<NEW>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}