$re = '/&#\w+;(*SKIP)(*F)|;/';
$str = 'ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;';
$subst = "<NEW>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;