use strict;
my $str = 'ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;';
my $regex = qr/&#\w+;(*SKIP)(*F)|;/p;
my $subst = '<NEW>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";