import re
regex = re.compile(r"&#\w+;(*SKIP)(*F)|;")
test_str = ("ć;\n"
"Johć; Smith <js@comms.com>;\n"
";boomʿ;woopwoop;\n"
";")
subst = "<NEW>"
result = regex.sub(subst, test_str)
if result:
print(result)