# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?/while ($1){$2}/gm;t' <<< " While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}"