const regex = /While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('While +([^\\n\\;]+);?((?:[ \\t]*(?!Wend)(?:\\S+[ \\t]*)*\\n)+[ \\t]*)Wend[ \\t]*\\;?', 'gm')
const str = ` While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}`;
const subst = `while ($1){$2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);