re = /While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?/m
str = ' While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}'
subst = 'while ($1){$2}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result