# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?"
test_str = (" While x > 0;\n"
" string y = x Mod 2;\n"
" ret = y + ret;\n"
" x = x / 2\n"
" Wend;\n"
" \n"
"While Not Eof(file);\n"
"x = x / 2\n"
" Wend;\n\n"
"While Wend => while{}")
subst = "while ($1){$2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.