$re = '/While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?/m';
$str = ' While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}';
$subst = "while ($1){$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;