using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?";
string substitution = @"while ($1){$2}";
string input = @" While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}