#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?"
Local $sString = " While x > 0;" & @CRLF & _
" string y = x Mod 2;" & @CRLF & _
" ret = y + ret;" & @CRLF & _
" x = x / 2" & @CRLF & _
" Wend;" & @CRLF & _
" " & @CRLF & _
"While Not Eof(file);" & @CRLF & _
"x = x / 2" & @CRLF & _
" Wend;" & @CRLF & _
"" & @CRLF & _
"While Wend => while{}"
Local $sSubst = "while ($1){$2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)